Go Back   Access World Forums > Apps and Windows > Other Software

 
Reply
 
Thread Tools Rate Thread Display Modes
Old 03-03-2006, 12:43 PM   #1
W.Dnx.W
Registered User
 
W.Dnx.W's Avatar
 
Join Date: Feb 2006
Location: Croatia
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
W.Dnx.W is an unknown quantity at this point
Question Accessing FTP

Hi...
I'm having a weird problem...I'm having two computers connected over UTP crossover cable. Mine has an internet connection (shared, firewalled) and the other one is sharing that same connection. How is it possible taht I can't connect to ftp and the other pc can, since it is on the same connection as I am.

I've tried with firewall turned of, tried to put some exceptions to connecting over different software, and I have set my connection to have FTP service available in advanced properties.

All is running on WinXp with SP2


Daniel

W.Dnx.W is offline   Reply With Quote
Old 03-03-2006, 01:16 PM   #2
Minkey
Newly Registered User
 
Minkey's Avatar
 
Join Date: Jul 2004
Location: London, UK
Posts: 661
Thanks: 0
Thanked 8 Times in 8 Posts
Minkey will become famous soon enough
One thing you could try is to install the NETBEUI protocol on both machines (it's an old MS protocol used specifically for PC to PC comms) guide here (if your using WinXP that is)
__________________
__________________________________________________
"People should not be afraid of their governments.
Their governments should be afraid of their people" V
.................................................. .....................

Schrodinger's cat walks into a bar........and doesn't
Minkey is offline   Reply With Quote
Old 03-03-2006, 01:23 PM   #3
W.Dnx.W
Registered User
 
W.Dnx.W's Avatar
 
Join Date: Feb 2006
Location: Croatia
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
W.Dnx.W is an unknown quantity at this point
I'm not really sure if that is what I need...I may try if I don't get any progress..the thing is I had it all up and running 2 months ago...then I had to reinstall my PC. No I have XP with SP2 and the other one is still XP with sp1...could be that something in sp2 is not set up right...

both are XP PRO...

D

W.Dnx.W is offline   Reply With Quote
Old 03-03-2006, 01:49 PM   #4
Minkey
Newly Registered User
 
Minkey's Avatar
 
Join Date: Jul 2004
Location: London, UK
Posts: 661
Thanks: 0
Thanked 8 Times in 8 Posts
Minkey will become famous soon enough
Ah if it worked before then yes NETBEUI probably wouldn't help.
It looks like SP2 as changed some sort of settings are you sure the windows firewall is not enabled (as SP2 activates that by default) and it also blocks ports 20 and 21 which are required for ftp see here for a full list.

BTW which firewall do you use on your main PC ?
__________________
__________________________________________________
"People should not be afraid of their governments.
Their governments should be afraid of their people" V
.................................................. .....................

Schrodinger's cat walks into a bar........and doesn't
Minkey is offline   Reply With Quote
Old 03-04-2006, 12:08 AM   #5
W.Dnx.W
Registered User
 
W.Dnx.W's Avatar
 
Join Date: Feb 2006
Location: Croatia
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
W.Dnx.W is an unknown quantity at this point
well, windows firewall is enabled...but even if I disable it, no change..and I have given perrmision for the FTP service for the port 21...dunno

D
W.Dnx.W is offline   Reply With Quote
Old 03-04-2006, 12:13 AM   #6
W.Dnx.W
Registered User
 
W.Dnx.W's Avatar
 
Join Date: Feb 2006
Location: Croatia
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
W.Dnx.W is an unknown quantity at this point
Still, thanks a lot for the info...I'll search out the microsoft support site...it seems I may get it to work...
D
W.Dnx.W is offline   Reply With Quote
Old 03-06-2006, 12:07 PM   #7
W.Dnx.W
Registered User
 
W.Dnx.W's Avatar
 
Join Date: Feb 2006
Location: Croatia
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
W.Dnx.W is an unknown quantity at this point
NOpe, ntohing new...I've looked into Microsfot web but it doesn't help....
I've tried to open my port 21 manually but still nothing...
any ideas?

D

W.Dnx.W is offline   Reply With Quote
Old 03-07-2006, 10:12 AM   #8
Minkey
Newly Registered User
 
Minkey's Avatar
 
Join Date: Jul 2004
Location: London, UK
Posts: 661
Thanks: 0
Thanked 8 Times in 8 Posts
Minkey will become famous soon enough
You haven't said what type of ftp software you are using (if any) have you tried via windows explorer and IE, I'd also suggest something a bit more destructive

Unistall and reinstall of your FTP software (you've probably already done this as you said you had reinstalled windows)
Try a different ftp prog like Smart FTP - it's free

This is the best I can do without seeing your PC - so far (I don't give up easily)
__________________
__________________________________________________
"People should not be afraid of their governments.
Their governments should be afraid of their people" V
.................................................. .....................

Schrodinger's cat walks into a bar........and doesn't
Minkey is offline   Reply With Quote
Old 03-08-2006, 12:33 AM   #9
W.Dnx.W
Registered User
 
W.Dnx.W's Avatar
 
Join Date: Feb 2006
Location: Croatia
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
W.Dnx.W is an unknown quantity at this point
Well, I've tried through IE, FireFox, I had CUte FTP as well, and now I0m using ftp through Win Commander...The thing is that all worked well before I reinstalled my Xp, so I supposed it has to do something with SP2 which I didn't had before...
and what seems funny is that other PC on my network CAN connect over FTP although it's going through my pc internet connection...which, I suppose, means that my connection is properly set up, but somehow I'm blocked

D
W.Dnx.W is offline   Reply With Quote
Old 03-08-2006, 06:25 AM   #10
pono1
Newly Registered User
 
Join Date: Jun 2002
Posts: 1,186
Thanks: 0
Thanked 0 Times in 0 Posts
pono1 will become famous soon enough
XP SP2 came with tighter security -- what this meant from the programming side is that some Windows APIs that worked under previous Windows versions stopped working under XP SP2. This is why so many developers were scrambling when XP2 was released...

Best guess as far as your problem goes...

In Internet Explorer, go to Internet options
Click on the Advanced tab
Uncheck Use Passive FTP

Otherwise: You can check here...

Regards,
Tim
pono1 is offline   Reply With Quote
Old 03-10-2006, 01:20 AM   #11
W.Dnx.W
Registered User
 
W.Dnx.W's Avatar
 
Join Date: Feb 2006
Location: Croatia
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
W.Dnx.W is an unknown quantity at this point
I've tryed what U suggested but still without results...
I did visit MS page and did that few days ago...but still with no results...there has to be something simple...just think off people who are web designers who tried to upload their sites after installing SP2...weird...
W.Dnx.W is offline   Reply With Quote
Old 03-10-2006, 06:26 AM   #12
pono1
Newly Registered User
 
Join Date: Jun 2002
Posts: 1,186
Thanks: 0
Thanked 0 Times in 0 Posts
pono1 will become famous soon enough
Mmm. Yes, many people with XP SP2 use ftp each and every day. Wish I could be of more help. Off the top of my head:

1. Tools-Internet Options-Security -- carefully compare the custom settings on the machine that is working with the machine that does not.
2. Double-and triple-check, one at a time, that all firewall and anti-virus programs are disabled on the problem machine.
3. Continue searching the web: As you suggest, someone, somewhere must have also had this problem.
4. Continue to check the software vendors' -- Cute FTP, etc -- web sites.
5. I would also not worry too much about ports 20 and 21...these ports are used by FTP servers, not FTP clients.

Regards,
Tim
pono1 is offline   Reply With Quote
Old 03-10-2006, 10:13 AM   #13
Minkey
Newly Registered User
 
Minkey's Avatar
 
Join Date: Jul 2004
Location: London, UK
Posts: 661
Thanks: 0
Thanked 8 Times in 8 Posts
Minkey will become famous soon enough
What anti-virus are you running ? There is an issue regarding Norton 2006 (or an upgrade from 2005) you need to add alg.exe to the rules see below for a full explination (regarding WS-FTP but it should apply to any other) BTW I've pasted it as it's buried in a thread.

I'm not going to give up on this !! - There is of course the final option to reinstall windows but of course you don't want to do that !

Quote:
Open Norton AntiVirus 2005
- Click "Options"
-- Click "Internet Worm Protection"
--- Make sure "Enable Internet Worm Protection (recommended)" is checked.
--- Click "Trojan Rules"
---- Uncheck "Unused Windows Services Block", (all the way at the bottom of the list)
---- "OK"
--- "OK"
.
Connect to a site in WS-FTP. (It'll work.)
.
Go back to Norton
- Click "Options"
-- Click "Internet Worm Protection"
--- Click "Program Control"
---- You should see a new entry, "Microsoft Application Layer Gateway Service". It should be configured as "Automatic". This is what fixed the problem. (You don't have to make any changes here; this step was just to let you see the new entry.)
---- "OK"
--- Click "Trojan Rules"
---- Put the checkmark back into "Unused Windows Services Block"
---- "OK"
--- "OK"
Close Norton
.
You should now be able to connect with WS-FTP the same as you could before installing Norton AntiVirus 2005.
.
One other thing: if you have Windows XP Pro Service Pack 2 installed, you may at some point have to tell Windows Firewall to not block WS-FTP. To do so,
.
Open the Windows Control Panel
- Click "Windows Firewall"
-- Click the "Exceptions" tab
--- Click "Add Programs"
---- Check "WS_FTP Pro"
----- The Scope should be set to "Any computer (including those on the Internet)".
__________________
__________________________________________________
"People should not be afraid of their governments.
Their governments should be afraid of their people" V
.................................................. .....................

Schrodinger's cat walks into a bar........and doesn't
Minkey is offline   Reply With Quote
Old 03-13-2006, 01:55 AM   #14
W.Dnx.W
Registered User
 
W.Dnx.W's Avatar
 
Join Date: Feb 2006
Location: Croatia
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
W.Dnx.W is an unknown quantity at this point
maybe that's it...I know I had some issues with alg.exe before, when I was putting another firewall up...I'll try that...thanks a lot
W.Dnx.W is offline   Reply With Quote
Old 03-13-2006, 01:08 PM   #15
W.Dnx.W
Registered User
 
W.Dnx.W's Avatar
 
Join Date: Feb 2006
Location: Croatia
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
W.Dnx.W is an unknown quantity at this point
guys...That was it...now everything seems to be OK...thanks a lot Minkey
see ya around

W.Dnx.W is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP Upload Module gisash1 General 12 01-21-2010 05:07 AM
FTP upload w/MSINET.OCX: PROBLEM sard0nicpan Modules & VBA 1 11-13-2007 08:29 AM
Where did my FTP transfered file go? DKDiveDude Modules & VBA 2 10-20-2003 09:21 AM
import from a file in FTP server meix Modules & VBA 0 04-28-2003 12:53 PM
FTP import/export through Access? NJudson General 2 01-18-2003 10:04 AM




All times are GMT -8. The time now is 06:10 PM.


Microsoft Access Help
General
Tables
Queries
Forms
Reports
Macros
Modules & VBA
Theory & Practice
Access FAQs
Code Repository
Sample Databases
Video Tutorials

Featured Forum post


Sponsored Links


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
(c) copyright 2017 Access World