Go Back   Access World Forums > Apps and Windows > Crystal Reports

 
Reply
 
Thread Tools Rate Thread Display Modes
Old 11-23-2015, 05:13 AM   #1
bjsteyn
Newly Registered User
 
Join Date: May 2008
Posts: 111
Thanks: 1
Thanked 9 Times in 9 Posts
bjsteyn is on a distinguished road
Crystal Reports problem on Windows 10

Hi,

I am wondering if someone can help me ... I wrote a system in VB.Net 2012 (Visual Studio Express 2012). It has been running fine on Windows 7 32bit but our client wishes to upgrade to Windows 10 32 bit now. I am busy testing the system on 64bit Windows 10 and it works fine on my Windows 7 64 bit. I am having the following problem with Crystal Reports.

Whenever a reports load i get the following error. See attached image ...

This is my code that odbc connections settings to the report ....

------------------------------------------------------------------------------------------------

Dim ciReportConnection As New CrystalDecisions.Shared.ConnectionInfo

ciReportConnection.ServerName = "Driver={" & Configs.odbc_driver & "};Server=" & configDB.dbconfig.Host & ";Port=" & configDB.dbconfig.Port & ";"
ciReportConnection.DatabaseName = configDB.dbconfig.Database
ciReportConnection.UserID = configDB.dbconfig.Username
ciReportConnection.Password = configDB.dbconfig.Password


objReportDocument.SetDatabaseLogon(configDB.dbconf ig.Username, configDB.dbconfig.Password, "Driver={" & Configs.odbc_driver & "};Server=" & configDB.dbconfig.Host & ";Port=" & configDB.dbconfig.Port & ";", configDB.dbconfig.Database)

'//Assign data source details to tables

For Each table In objReportDocument.Database.Tables
table.LogOnInfo.ConnectionInfo = ciReportConnection
table.ApplyLogOnInfo(table.LogOnInfo)
Next

------------------------------------------------------------------------------------------------

It only happens on Windows 10. I dont have a problem on Windows 7.
Attached Images
File Type: png Untitled.png (27.6 KB, 342 views)

bjsteyn is offline   Reply With Quote
Old 11-23-2015, 05:44 AM   #2
bjsteyn
Newly Registered User
 
Join Date: May 2008
Posts: 111
Thanks: 1
Thanked 9 Times in 9 Posts
bjsteyn is on a distinguished road
Re: Crystal Reports problem on Windows 10

Problem Solved. The odbc driver never installed when i installed it. lol, always something stupid.
bjsteyn is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Crystal Reports - Conditional Suppress problem Devin.McQuaid Reports 0 02-05-2013 02:26 PM
Crystal Report Problem with sub reports that contain large volumes of data Wayne69 Crystal Reports 2 12-01-2009 07:27 AM
Strange formatting problem with Crystal Reports Sathyaish Crystal Reports 1 10-27-2009 10:26 PM
Crystal Reports Summing-Grouping Problem krazykasper Crystal Reports 0 02-26-2009 01:05 PM
PEOpenEngine() API calls in crystal reports xi/ crystal reports 2008 sumita2008 Crystal Reports 0 04-07-2008 10:31 AM




All times are GMT -8. The time now is 09:50 AM.


Microsoft Access Help
General
Tables
Queries
Forms
Reports
Macros
Modules & VBA
Theory & Practice
Access FAQs
Code Repository
Sample Databases
Video Tutorials

Featured Forum post


Sponsored Links


Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
(c) copyright 2017 Access World